maven ssm 框架搭建问题解决

昨天搭建这个框架用了很久,但总是报错,把mybatis和spring整合后,单元测试都不成功!

问题根源:创建maven2项目,会自动将JRE System Library 默认设置为JavaSE-1.5,我们可以手动修改它的版本(框架运行时还是会出错),而且 maven -> Update Project.. 之后又会回到javaSE-1.5,解决办法:

在 pom.xml 的 <build>标签中</build> 添加如下说明

<plugins>  
        <plugin>    
        <groupId>org.apache.maven.plugins</groupId>    
        <artifactId>maven-compiler-plugin</artifactId>    
        <configuration>    
            <source>1.8</source>    
            <target>1.8</target>    
        </configuration>    
        </plugin>  
</plugins>

1.8 是你想在这个项目中使用的 jdk 版本(你本地的jdk版本);

添加完后保存,再 maven -> Update Project… ,你可以看到 JRE System Library已经变更为你要求的版本,再启动项目,一切OK。

————————————-

错误记录:

1.在复制下方框架搭建教程的 jdbc.properties 代码的时候,复制到本地记得整理一下代码,把后面空格删掉,都则会报错!

2.原教程jdbc.properties文件url不完整,导致Spring和mybatis整合单元测试不成功!(url=jdbc:mysql://localhost:3306/db_zsl?useUnicode=true&characterEncoding=utf8

框架搭建:http://blog.csdn.net/zhshulin/article/details/37956105

问题参考:http://jynine.iteye.com/blog/1890842


293 Clicks !

发表评论

电子邮件地址不会被公开。