error: Failed dependencies: /usr/bin/perl is needed by mysql-community-server-5.7.22-1.el6.x86_64 libnuma.so.1()(64bit) is needed by mysql-community-server-5.7.22-1.el6.x86_64

linux在安装mysql的时候,有4个rpm包需要安装,但是安装到第四个 ,执行下面命令后,突然报错

rpm -ivh mysql-community-server-5.7.22-1.el6.x86_64.rpm

报错信息如下:

error: Failed dependencies: /usr/bin/perl is needed by mysql-community-server-5.7.22-1.el6.x86_64 libnuma.so.1()(64bit) is needed by mysql-community-server-5.7.22-1.el6.x86_64

解决方法:执行下面这条命令,安装perl依赖

yum install -y perl-Module-Install.noarch

执行完后,我又去执行了最上面的代码,还是会报错,忘了收集错误代码,我又执行了下面命令

yum install -y perl

然后又去执行了最上面的代码,还是有毛病,缺少某些东西

error: Failed dependencies:libnuma.so.1()(64bit) is needed by mysql-community-server-5.7.22-1.el6.x86_64

参考:http://www.iteye.com/problems/130971


222 Clicks !

发表评论

电子邮件地址不会被公开。 必填项已用*标注